/* Modified for emx by hv 1996
 * Modified for gcc/os2 by bird 2003
 *
 * Copyright (c) 1982, 1986 Regents of the University of California.
 * All rights reserved.
 *
 * Redistribution and use in source and binary forms, with or without
 * modification, are permitted provided that the following conditions
 * are met:
 * 1. Redistributions of source code must retain the above copyright
 *    notice, this list of conditions and the following disclaimer.
 * 2. Redistributions in binary form must reproduce the above copyright
 *    notice, this list of conditions and the following disclaimer in the
 *    documentation and/or other materials provided with the distribution.
 * 3. All advertising materials mentioning features or use of this software
 *    must display the following acknowledgement:
 *	This product includes software developed by the University of
 *	California, Berkeley and its contributors.
 * 4. Neither the name of the University nor the names of its contributors
 *    may be used to endorse or promote products derived from this software
 *    without specific prior written permission.
 *
 * THIS SOFTWARE IS PROVIDED BY THE REGENTS AND CONTRIBUTORS ``AS IS'' AND
 * ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
 * IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE
 * ARE DISCLAIMED.  IN NO EVENT SHALL THE REGENTS OR CONTRIBUTORS BE LIABLE
 * FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL
 * DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS
 * OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION)
 * HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT
 * LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY
 * OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF
 * SUCH DAMAGE.
 *
 *	from: @(#)tcp.h	7.7 (Berkeley) 6/28/90
 *	$Id: tcp.h,v 1.4 1994/01/08 21:21:56 mycroft Exp $
 */

#ifndef _NETINET_TCP_H_
#define _NETINET_TCP_H_

#include <machine/endian.h>

typedef	u_long	tcp_seq;
/*
 * TCP header.
 * Per RFC 793, September, 1981.
 */
#pragma pack(1)
struct tcphdr {
	u_short	th_sport;		/* source port */
	u_short	th_dport;		/* destination port */
	tcp_seq	th_seq;			/* sequence number */
	tcp_seq	th_ack;			/* acknowledgement number */
#ifdef TCPV40HDRS
#if BYTE_ORDER == LITTLE_ENDIAN
        u_int   th_x2:4,                /* (unused) */
                th_off:4,               /* data offset */
                th_flags:8,
                th_win:16;
#endif
#if BYTE_ORDER == BIG_ENDIAN
        u_int   th_win:16,
                th_flags:8,
                th_off:4,               /* data offset */
                th_x2:4;                /* (unused) */
#endif
#define TH_FIN  0x01
#define TH_SYN  0x02
#define TH_RST  0x04
#define TH_PUSH 0x08
#define TH_ACK  0x10
#define TH_URG  0x20
#else
#if BYTE_ORDER == LITTLE_ENDIAN
	u_char	th_x2:4,		/* (unused) */
		th_off:4;		/* data offset */
#endif
#if BYTE_ORDER == BIG_ENDIAN
	u_char	th_off:4,		/* data offset */
		th_x2:4;		/* (unused) */
#endif
	u_char	th_flags;
#define	TH_FIN	0x01
#define	TH_SYN	0x02
#define	TH_RST	0x04
#define	TH_PUSH	0x08
#define	TH_ACK	0x10
#define	TH_URG	0x20
	u_short	th_win;			/* window */
#endif
	u_short	th_sum;			/* checksum */
	u_short	th_urp;			/* urgent pointer */
};
#pragma pack()

#define	TCPOPT_EOL	0
#define	TCPOPT_NOP	1
#define	TCPOPT_MAXSEG	2
#ifndef TCPV40HDRS
#define    TCPOLEN_MAXSEG               4
#define TCPOPT_WINDOW           3
#define    TCPOLEN_WINDOW               3
#define TCPOPT_SACK_PERMITTED   4               /* Experimental */
#define    TCPOLEN_SACK_PERMITTED       2
#define TCPOPT_SACK             5               /* Experimental */
#define TCPOPT_TIMESTAMP        8
#define    TCPOLEN_TIMESTAMP            10
#define    TCPOLEN_TSTAMP_APPA          (TCPOLEN_TIMESTAMP+2) /* appendix A */

#define TCPOPT_CC               11              /* CC options: RFC-1644 */
#define TCPOPT_CCNEW            12
#define TCPOPT_CCECHO           13
#define    TCPOLEN_CC                   6
#define    TCPOLEN_CC_APPA              (TCPOLEN_CC+2)
#define    TCPOPT_CC_HDR(ccopt)         \
    (TCPOPT_NOP<<24|TCPOPT_NOP<<16|(ccopt)<<8|TCPOLEN_CC)
#define TTCP_CLIENT_SND_WND   4096 /* dflt send window of ttcp client */
#define TCPOPT_TSTAMP_HDR       \
    (TCPOPT_NOP<<24|TCPOPT_NOP<<16|TCPOPT_TIMESTAMP<<8|TCPOLEN_TIMESTAMP)
#endif /*!TCPV40HDRS*/

/*
 * Default maximum segment size for TCP.
 * With an IP MSS of 576, this is 536,
 * but 512 is probably more convenient.
 * This should be defined as MIN(512, IP_MSS - sizeof (struct tcpiphdr)).
 */
#ifdef TCPV40HDRS
#ifdef  lint
#define TCP_MSS 536
#else
#ifndef IP_MSS
#define IP_MSS  576
#endif
#define TCP_MSS MIN(512, IP_MSS - 40)
#endif
#else /* TCPV40HDRS*/
#define	TCP_MSS	512
#endif

#define	TCP_MAXWIN	65535		/* largest value for window */

#ifndef TCPV40HDRS
#define TCP_MAX_WINSHIFT        14      /* maximum window shift */
#endif

/*
 * User-settable options (used with setsockopt).
 */
#define	TCP_NODELAY	0x01	/* don't delay send to coalesce packets */
#define	TCP_MAXSEG	0x02	/* set maximum segment size */
#ifndef TCPV40HDRS
#define TCP_MSL         0x03    /* MSL HACK */
#define TCP_TIMESTMP    0x04    /* RFC 1323 (RTTM TimeStamp)   */
#define TCP_WINSCALE    0x05    /* RFC 1323 (Window Scale)     */
#define TCP_CC          0x06    /* RFC 1644 (Connection Count) */
#ifdef VEGAS
#define TCP_TAHOE                       3
#define TCP_RENO                        4
#define TCP_VEGAS                       5
#define TCP_VEGAS_SPIKE_ON              6
#define TCP_VEGAS_EXP_INC_OFF           7
#define TCP_VEGAS_CONG_DETECT_OFF       8
#define TCP_VEGAS_24                    9
#define TCP_VEGAS_CONG_DETECT_PRED_ON   10
#endif
#endif /*!TCPV40HDS*/

#ifdef TCPV40HDRS
#include <netinet/tcp_var.h>
#endif

#endif /* !_NETINET_TCP_H_ */
